UnsupportedMethodException Android Studio 0.8.9

I have Android Studio 0.8.9.
Until now, It could sync with gradle files successfully,
But today when I opened it, It gives me this error:

UnsupportedMethodException
         Failed to set up Android modules in project 'Project': Unsupported method: SourceProvider.getJniDirectories().
         The version of Gradle you connect to does not support that method.
         To resolve the problem you can change/upgrade the target version of Gradle you connect to.
         Alternatively, you can ignore this exception and read other information from the model.

Can you help me solve this? Thanks.

  • Android Calendar, get Event Id
  • Exporting APK from eclipse (ADT) silently crashes
  • How to properly remove padding (or margin?) around buttons in Android?
  • Android - Frame layout height not matching with coordinator layout
  • Android java.lang.RuntimeException: Unable to instantiate activity ComponentInfo
  • Phonegap - Choose Image From Gallery
  • Related posts:

    Data out of sync between a custom CursorLoader and a CursorAdapter backing a ListView
    Android xml vs java layouts performance
    How to align Radio button at the center of the screen
    Hiding strings in Obfuscated code
    Formatting a calendar date
    Lineargradient is drawn offset from specified positon
  • How to programmatically set a lock or pin for an app
  • Android integration with CCAvenue
  • What happens on Activity.finish() with AsyncTask still running in background?
  • Android: Create new System Permission in through AOSP source code.
  • Run Android without GUI (headless Android)
  • How to exit adb logcat
  • 2 Solutions collect form web for “UnsupportedMethodException Android Studio 0.8.9”

    As stated by Justin, Upgrading to Android Studio 0.9.0 fixes this issue.

    To correct this issue I down-graded the android-plugin in your projects top level build.gradle file from
    classpath ‘com.android.tools.build:gradle:0.14.+’
    to
    classpath ‘com.android.tools.build:gradle:0.13.+’

    So right now the buildscript method in my projects build.grade looks like

    buildscript {
      repositories {
        mavenCentral()
      }
      dependencies {
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
        classpath 'com.android.tools.build:gradle:0.13.+'
      }
    }
    

    I think there may be a bug with version .14, I sent my error report.

    Android Babe is a Google Android Fan, All about Android Phones, Android Wear, Android Dev and Android Games Apps and so on.