How does one upgrade to Android SDK 25.1.3?

After the latest update to Xamarin, I get this error in design view

“The installed Android SDK is too old. Version 25.1.3 or newer is required.”

  • Android Camera Set Resolution
  • Android 4.4 KitKat random crash (Native crash at /system/lib/libc.so)
  • How can I send emails from my Android application?
  • Change color inside strings.xml
  • Should adapters in Android be static inner classes or non-static inner classes
  • How to make layout with View fill the remaining space?
  • Running the “Open Android SDK” and installing the latest version of Android Studio did not resolve the issue.

    Related posts:

    Java / Android - How to print out a full stack trace?
    Streaming voice between Android Phones over WiFi
    what is android.R.layout.simple_list_item_1?
    Android: How to add listener to hardware menu button?
    Genymotion devices not working in Eclipse on OS X Yosemite
    Set theme color dynamically
  • Tracing the Memory/Window Leaks in Android?
  • Create Email account from type existing Account Services
  • Publishing my first android application in Android market
  • how voice recognition in android works?
  • Read WCF REST date from android
  • Getting Nexus S Android NFC into Card emulation mode
  • 8 Solutions collect form web for “How does one upgrade to Android SDK 25.1.3?”

    I got past this by installing SDK v23 (Android 6.0). When designer mode finally opened, even though I also have Android 7.0 installed, Android 6.0 was the only selectable “Version” at the top of designer mode. I have Visual Studio 2015 btw.

    So, I just figured this out and remembered this post, I’ve been struggling with this issue for hours now.

    The problem seems to be that Xamarin doesn’t recognize the latest SDK Tools (25.2.2) as a newer version than the minimum needed (25.1.3) so I tried downloading the SDK Tools with the same minor version as the needed one, closest I could find was 25.1.7 which you can get from the Google repository here:

    Just extract the appropriate package for your platform into your SDK directory under tools and re-open Xamarin/Visual Studio and the Android designer should work again.

    To open the SDK Manager, click Tools > Android > SDK Manager or click SDK Manager in the toolbar.

    When an update is available for a package you already have, a dash appears in the check box next to the package.

    To update an item or install a new one, click the check box so it shows a checkmark.
    To uninstall a package, click to clear the check box.
    Pending updates are indicated in the left column with a download icon . Pending removals are indicated with a red cross .

    To update the selected packages, click Apply or OK, then agree to any license agreements.

    more details Refer Here with image

    Here is the process that worked for me:

    1. Install 64-bit JDK 1.8
    2. Update Android SDK Tools, Platform-tools, and Build-tools. Close SDK
      Manager and repeat if the version required in the warning isn’t
      shown. You may need to exit Visual Studio if you get “Warning! A
      folder failed to be moved”
    3. Make sure the Android settings in Visual Studio are pointing to the
      right locations: Tools > Options > Xamarin > Android Settings

    This is the full post about what I did to resolve this issue.

    Iliya was almost there. My setup is: non-fresh VS2015E U3, Xamarin 4.2.0.695, Android SDK installer 24.4.1, Android NDK R13, JDK 7u71. Tried Iliya method (and much more), reinstall, move Android SDK, nothing helped.

    Finally the solution was to install all Android SDK Tools from API 14 (Android 4.0) up to the latest using Android SDK manager. Source: https://forums.xamarin.com/discussion/47251/the-installed-android-sdk-is-too-old-version-24-3-or-newer-is-required see YuryShpakov answer.

    Though, there was more to do, at least for me: JDK 7 won’t compile your blank Android app, you have to go for JDK 8, and also uninstall JDK 7, if you can afford. See Rob’s resolve here: Warning major version 52 is newer than 51, the highest major version supported by this compiler

    One more issue will likely come up, see this thread: Error message "No exports were found that match the constraint contract name".

    May be this will help someone. Xamarin Studio has some weird file paths. Instead of checking files in Android SDK folder:
    /Users//Library/Android/sdk
    it checks them in
    /Users//Library/Developer/Xamarin/android-sdk-macosx

    I installed latest platform and tools using Android SDK Manager, and them copied them to android-sdk-macosx folder myself. This helped me.

    Apparently, my problem was solved after installing SDK Platform for Android 6.0 or API 23. Installing API 24 or higher i.e Android 7.x (Nougat) did not run. If still not solved then install SDK Platform for even lower APIs like 22,21 …
    Hope it helps.

    After install android 6 (api 23) problem The “installed Android SDK is too old. Version 25.1.3 or newer is required.” is Fixed.

    • ndk version : android-ndk-r13b
    • sdk version : API 25 & API 23 are installed
    • jdk version : jdk1.8.0_112 64 bit
    • xamarin version : 4.2.1.641
    Android Babe is a Google Android Fan, All about Android Phones, Android Wear, Android Dev and Android Games Apps and so on.