conflicting dependency when trying to install ADT plugin into eclipse

Here are my specs:
Eclipse: 3.5.2
ADT plugin: 11.0.0
PC: Windows 7

So far, I’ve installed the Android SDK and Eclipse. However when I attempt to install the ADT plugin into eclipse I get the following error:

  • Android open browser from service avoiding multiple tabs
  • blank space when scaling imageview in gridview
  • How to implement a ContentObserver for call logs
  • Picasso and PhotoView Library loads image into ImageView weird
  • Show only two digit after decimal
  • unicode support in android ndk
  • Cannot complete the install because of a conflicting dependency.
      Software being installed: Android Development Tools
    

    11.0.0.v201105251008-128486 (com.android.ide.eclipse.adt.feature.group
    11.0.0.v201105251008-128486)
    Software currently installed: Eclipse SDK 3.5.2.M20100211-1343
    (org.eclipse.sdk.ide
    3.5.2.M20100211-1343)
    Only one of the following can be installed at once:
    Core Runtime 3.6.0.v20100505 (org.eclipse.core.runtime
    3.6.0.v20100505)
    Core Runtime 3.5.0.v20090525 (org.eclipse.core.runtime
    3.5.0.v20090525)
    Cannot satisfy dependency:
    From: Android Development Tools 11.0.0.v201105251008-128486
    (com.android.ide.eclipse.adt.feature.group
    11.0.0.v201105251008-128486)
    To: org.eclipse.wst.sse.core 0.0.0
    Cannot satisfy dependency:
    From: EMF Common 2.6.0.v20100614-1136 (org.eclipse.emf.common
    2.6.0.v20100614-1136)
    To: bundle org.eclipse.core.runtime [3.6.0,4.0.0)
    Cannot satisfy dependency:
    From: EMF Common 2.6.0.v20100914-1218 (org.eclipse.emf.common
    2.6.0.v20100914-1218)
    To: bundle org.eclipse.core.runtime [3.6.0,4.0.0)
    Cannot satisfy dependency:
    From: Eclipse Platform 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB (org.eclipse.platform.feature.group
    3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB)
    To: org.eclipse.rcp.feature.group
    [3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6]
    Cannot satisfy dependency:
    From: Eclipse RCP 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6
    (org.eclipse.rcp.feature.group
    3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6)
    To: org.eclipse.core.runtime [3.5.0.v20090525]
    Cannot satisfy dependency:
    From: Eclipse Project SDK 3.5.2.R35x_v20100119-7Q7bARBPWUHM_CSjz-8bF1f7_n8rLSyWHoiKoyxBQSGT4
    (org.eclipse.sdk.feature.group
    3.5.2.R35x_v20100119-7Q7bARBPWUHM_CSjz-8bF1f7_n8rLSyWHoiKoyxBQSGT4)
    To: org.eclipse.platform.feature.group
    [3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB]
    Cannot satisfy dependency:
    From: Eclipse SDK 3.5.2.M20100211-1343 (org.eclipse.sdk.ide
    3.5.2.M20100211-1343)
    To: org.eclipse.sdk.feature.group
    [3.5.2.R35x_v20100119-7Q7bARBPWUHM_CSjz-8bF1f7_n8rLSyWHoiKoyxBQSGT4]
    Cannot satisfy dependency:
    From: Structured Source Model 1.1.500.v201006020308 (org.eclipse.wst.sse.core
    1.1.500.v201006020308)
    To: bundle org.eclipse.emf.common [2.4.0,3.0.0)
    Cannot satisfy dependency:
    From: Structured Source Model 1.1.502.v201008311901 (org.eclipse.wst.sse.core
    1.1.502.v201008311901)
    To: bundle org.eclipse.emf.common [2.4.0,3.0.0)
    Cannot satisfy dependency:
    From: Structured Source Model 1.1.504.v201102160550 (org.eclipse.wst.sse.core
    1.1.504.v201102160550)
    To: bundle org.eclipse.emf.common [2.4.0,3.0.0)

    Any suggestions?
    I’ve seen a few posts about re-installing eclipse, but that’s something i’m not comfortable with doing because it was such a pain to find the 64-bit version in the first place.

    If you want to suggest re-installing eclipse, i’d greatly appreciate it if you found the download link for the windows 64-bit version. thx 🙂

    or if you know how to fix this error directly that would be really helpful 😀

    Related posts:

    how to increase the space between the elements in linearlayout in android?
    fling and pinchzoom for an imageview in one activity
    Connect to access point using QPython?
    Android — How to get a list of all available intent filters ?
    RecyclerView scrolls to top on notifyDataSetChanged in chat screen
    How to send multipart/form data to web server from android?
  • Changing the width of AutoCompleteTextView in Android
  • Create “Battery usage” intent android
  • Android without Java
  • What is the difference between getMeasuredHeight and getHeight
  • Dismiss dialog after screen orientation change
  • How to use Git correctly in Android Studio?
  • 5 Solutions collect form web for “conflicting dependency when trying to install ADT plugin into eclipse”

    It looks like the latest ADT version requires Eclipse Helios (3.6). That seems odd since I can’t find where that requirement is documented.

    You could try getting a new Eclipse version.
    You could also grab an earlier ADT version, though I’m having trouble finding that.

    If you are upgrading from 3.6 and you’ve unizipped the new eclipse in the old original location you will get a confliciting dependency error – only one of these can be installed at a time etc tc.
    In that case, delete your old eclipse folder completely. Unzip the new one again there and it will work! No need to add any repositories!

    I guess you can uninstall android SDK. Then first add or install adt plugin in eclipse. then on restarting eclipse it’s autmatically gonna ask you path for Android SDK. if not asks then just go to Window->prefrences->Android and set the path of the android sdk (unzipped android folder)(path to tools dir).

    Probably a bit lat for this but I was running Eclipse Helios 3.6 and got the same type of dependency conflict messages. I went under the help menu and did a check for updates and it updated the eclipse sdk. I did a restart and tried installing the ADT plugin again and it worked.

    Eclipse installs default to a workspace called workspace..this causes problems when you attempt to update, etc..as the metadata in the workspace stills has the previous eclipse version stuff in it..

    First make a copy of the workspace than delete it and try to install 3.7 and adt again and everything should work..

    BTW, from now on…name your eclipse workspace by eclipse version number to help avoid the problem.

    Android Babe is a Google Android Fan, All about Android Phones, Android Wear, Android Dev and Android Games Apps and so on.