Build Target and Min SDK version in Android

While creating an android project if i say that the Build Target of my Android porject is 2.2 (API Level is picked as 8) and in the text box for Min SDK version. If i put some value apart from the API level (smaller or greater than 8) of the build target then what happens?

Does the build happen according to the build target specified, but the application developed is compatible with the smaller android versions (if i specify API level < 8 ). Or the application developed is only compatible for the higher android version (if i specify API level > 8 ).

  • How to set a particular font for a button text in android?
  • How to use android pay api with nfc?
  • Vuforia vs. Metaio SDK vs. ARKit vs. D'Fusion Mobile vs. Layar SDK
  • How to use AsyncTask to show a ProgressDialog while doing background work in Android?
  • BitmapFactory.decodeResource returns a mutable Bitmap in Android 2.2 and an immutable Bitmap in Android 1.6
  • Disable address bar in Android webview
  • Can anyone please explain?

  • Facebook SDK 4.7.0 logs ClassNotFoundException for AppEventsLogger
  • DGPS corrections on Android
  • Add android:name=“something” to AndroidManifest.xml “application” tag from Cordova plugin.xml
  • Floating Action Button attached with anchor not hiding when scrolling RecyclerView items slow
  • Make linear layout selectable like a list item in a list view (Android)
  • Empty space between listview header and first item
  • 4 Solutions collect form web for “Build Target and Min SDK version in Android”

    Say you set the manifest API level to 4, then the app will work on any api 4 device provided. BUT the project will be built to API level 8 so if you have any post-level 4 api methods in your code then the app will crash.

    There is a similiar question already posted with an excellent answer:

    Read the post by Steve H.

    Android Min SDK Version vs. Target SDK Version

    You can only put min SDK version less than your target version,it tell that your application can support to that min SDK version,but you should confirm that your application should run under min SDK version supported devices since the Build target versions may use new APIs which are available for that specific version and those APIs may not available in min SDK versions

    ok.. if you have developed an application using particular sdk for instance Android 2.2 and your minSDKversion is < 8 then application is falsely declaring to android system that It can be installed in Android device having sdk version less than Android 2.2. In that case if application happens to install on Android 2.1 and if you re using API that are exculsiviely avaialbe in Android 2.2 platform and not on Android 2.1 then your application will crash on the device. if your minsdkversion > 8 then application won’t get installed on the device having Android sdk 2.2 or lower version

    Android Babe is a Google Android Fan, All about Android Phones, Android Wear, Android Dev and Android Games Apps and so on.