Tag: android-support-library

issue with windowTranslucentNavigation

i want to make my navigation bar translucent , so i did some thing like this : <style name=”BlueToolBar” parent=”Theme.AppCompat”> <item name=”windowActionBar”>false</item> <item name=”android:colorBackground”>@color/action_blue</item> <item name=”colorPrimary”>@color/action_blue</item> <item name=”colorPrimaryDark”>@color/status_bar</item> <item name=”android:windowTranslucentNavigation”>true</item> </style> and it is working nicely, but my toolbar and status bar are merged, when i use this: <style name=”BlueToolBar” parent=”Theme.AppCompat”> <item name=”windowActionBar”>false</item> <item name=”android:colorBackground”>@color/action_blue</item> […]

Android support library 23.4.0: android.support.v7.widget.TintContextWrapper cannot be cast to Activity

So I updated to the latest support libraries, and got a crash I am not able to fix. My build.gradle now has these dependencies: dependencies { compile ‘com.android.support:appcompat-v7:23.4.0’ compile ‘com.android.support:gridlayout-v7:23.4.0’ compile ‘com.android.support:support-v4:23.4.0’ compile ‘com.android.support:cardview-v7:23.4.0’ compile ‘com.android.support:recyclerview-v7:23.4.0’ compile ‘com.android.support:design:23.4.0’ // More stuff… } I had a working listener that is used to catch clicks and start […]

How to add Android Support v7 libraries in eclipse?

How do I add Android Support v7 libraries in eclipse? For example how do I add CardView to an eclipse android project? Note: This was a self answer question, so no need to waste your time making an answer. Of course, if you have anything to add, please do.

Android fragments – findFragmentByTag always returns null

I’ve had a look around and found a couple of questions with a similar topic, but nothing that helped in my case. I’m trying to access an existing active fragment using getSupportFragmentManager().findFragmentByTag(TAG), but it always returns null. Replies on similar questions suggested that it takes a while for the commit to be executed, so calling […]

Proguard Android App for LVL and Fragment Compatability Support

I’m trying to use Proguard against my app which will eventually incorporate LVL and In-app Billing. The problem I have is that Proguard keeps crashing my app on start and it’s hard to figure out what’s failing. I’m using the Android V4 support compatibility library and it seems to be blowing away that library as […]

BottomSheetBehavior is not work when design library update to 24.2.0

BottomSheetBehavior work properly in compile ‘com.android.support:design:24.1.1’ but when I update it to 24.2.0,it is not work.Is that a bug? This is my code: <?xml version=”1.0″ encoding=”utf-8″?> <android.support.design.widget.CoordinatorLayout xmlns:android=”http://schemas.android.com/apk/res/android” xmlns:app=”http://schemas.android.com/apk/res-auto” android:layout_width=”match_parent” android:layout_height=”match_parent” android:fitsSystemWindows=”true” > <LinearLayout android:id=”@+id/llScroll” android:layout_width=”match_parent” android:layout_height=”200dp” android:orientation=”vertical” android:background=”@color/blue_1″ app:layout_behavior=”android.support.design.widget.BottomSheetBehavior”> </LinearLayout> </android.support.design.widget.CoordinatorLayout>

Android JACK compiler error after upgrade to latest support library

–Android Studio 2.2.3 (Windows 10 64 bit) –Build Tools version 25 –Android Gradle Plugin Version 2.2.3 After upgrade to latest support libraries (25.1.0 from 23.4.0) and change of compile version (25 from 23) I get this error: Error:com.android.sched.util.config.PropertyIdException: Property ‘jack.library.import’ (in Options): element #7: The version of the library file ‘..\app\build\intermediates\transforms\preJackPackagedLibraries\debug\jars\8000\1f\classes-1b6639e8217419d056942b0dacd1542739f1709f.jar’ is not supported anymore. […]

getSupportLoaderManager() use same ids in different fragments?

I am making a viewPager in a FragmentActivity with multiple ListFragments. In order to populate the different listviews i get the LoaderManager and initiliaze in the loader. I wanted to have a unique LoaderManager for each fragment, however, fragments don’t have a getSupportLoaderManager() method so i need to call the parent fragment activity: getActivity().getSupportLoaderManager() The […]

Why is ContextThemeWrapper now restricted to the Support Library group?

I started using a ContextThemeWrapper to apply a style dynamically to an ImageButton; based an answer to another question of mine, and answers to other similar questions. ContextThemeWrapper wrapper = new ContextThemeWrapper(getContext(), mStyleRes); mImageButton = new AppCompatImageButton(wrapper, null, 0); But recently a lint error started appearing on the ContextThemeWrapper constructor stating: ContextThemeWrapper can only be […]

Android BottomSheet: Is hinding under the toolbar

I tried to use the new bottom sheet from the support library 23.2.0 to have a bottom sheet expand to full screen like suggested in the design guidelines This works very good but the bottom sheet goes under my ActionBar and under my Tabs. How is it possible to let it go over the toolbar? […]

Android Babe is a Google Android Fan, All about Android Phones, Android Wear, Android Dev and Android Games Apps and so on.