Tag: android-support-library

Android -RecyclerView in kitkat

since the RecyclerView src is in android.support.v7.widget.RecyclerView can i use the recyclerView in kit kat and jelly bean as long as i reference this package from the support library (or google play services)?

How to build v4 support library from source

I’m trying to build the v4 support library from source sice I modified a portion of the library. I’m trying to do this on ubuntu 13.10 with gradle. I followed the instructions in this answer, but now I’m stuck. I used gradle 1.10 with ubuntu since when I tried to build it on windows, it […]

Third Party FloatingActionButton Library in CoordinatorLayout

I am trying to use futuresimple’s FloatingActionButton library to use a FloatingActionMenu inside a CoordinatorLayout so when I display a Snackbar the FAB will move up and not be hidden by the Snackbar. The FloatingActionMenu is working perfectly although I have noticed the third-party library is not working inside the CoordinatorLayout. When I use the […]

How to set the elevation of an AppBarLayout programmatically in the Android Support Library v24.0.0?

When upgrading from the Android Support Library v23.4.0 to v24.0.0, setting the elevation to 0 programmatically to an AppBarLayout stopped working: appBayLayout.setElevation(0); It does work when setting the elevation in the XML.

Material Design support library

Are there efforts underway to backport the new Material Design style and widgets to pre-L versions of Android, similar to the “HoloEverywhere”-library? The creator of that library has initialized an empty GitHub-repository, but it doesn’t seem to be in active development. I know there is a backport of L-style dialogs and the floating action button, […]

Stop Android Studio from using Support Library

I’m trying to get my Android project in Android Studio to NOT use the Support library. My issue is that when I use fragments it is expecting support fragments and causing the app to crash. My Min SDK is 14 and my Target SDK is 19. My understanding is that because I’m targeting these versions […]

Custom RatingBar tinting API < 21 with support library 22.1.1

I’m using the support library 22.1.1. My goal is to tint a custom RatingBar to avoid having to include multiple images in my APK. The tinting is correctly applied on API 22, but not on API 19. I’d like it to work on API >= 16. Note that I’m trying to tint the “progress” only, […]

How to click views behind a Toolbar?

I have a toolbar with a transparent/translucent background that overlays the content. So, behind the toolbar, views can appear that are clickable. The problem is that they can not be clicked through the toolbar because the toolbar is catching the click event. I tried setting android:clickable=”false”, android:focusable=”false” and android:focusableInTouchMode=”false” for the toolbar, but it has […]

How to use NumberPicker in Android app with API 7?

The minimum sdk of my app is 7, but I can use DialogFragment which is from sdk version 11, because it is in the support library which is in my lib directory. I’d like to make something like this example: http://developer.android.com/guide/topics/ui/controls/pickers.html But I want to use the NumberPicker widget, which is from sdk version 11 […]

Failed to resolve: com.android.support:customtabs:

This question already has an answer here: Android studio default project fails: Error:Failed to resolve: com.android.support:support-v4:25.2.0 2 answers Failed to resolve: com.android.support:cardview-v7:26.0.0 android 10 answers

Android Babe is a Google Android Fan, All about Android Phones, Android Wear, Android Dev and Android Games Apps and so on.